Cannot configure Alpha+ RTK receiver


I cannot change configuration to Alpha+ RTK receiver using RTK Viewer I have set receiver’s baud rate to 19200 and 10 Hz refresh rate for Rover mode and then after reconnection of USB cable I cannot change any settings anymore. I am still able to connect to receiver via USB port at 19200 baud rate and get NMEA sentences, but menu Settings and Updates are greyed out. I have tried to set switch both to A and B position without any success. How to restore receiver’s baud rate to factory default 115200?


Alpha+ User Guide Appendix A-4 has explanation on the data flow. What you need is NMEA output and command input on USB port. Setting shown in below figure should allow you to properly configure Alpha+.



Sorry, I could not quite get your suggestion about data flow.

However, I was able to restore factory defaults on Alpha+ RTK receiver by means of GNSS Viewer Customer Release V2.1.056 for Phoenix (GNSS Viewer). From GNSS Viewer I connected to receiver on 19200 baud rate and performed Set Factory Default from Binary menu. Now everything works fine on 115200 baud rate.

I guess it could be a kind of RTK Viewer limitation to perform correct query of firmware version and firmware CRC code when Update rate set to max 10 Hz and port baud set to some lower value than 115200. That’s just my guess.

1 Like

At higher update rate, more data is being output, higher baud rate is required to provide sufficient bandwidth for communication. If setting to lower baud rate, the bandwidth is insufficient, something will not get through.

I agree. However, RTK Viewer, as a bus driver, should not allow 60 passengers to cram into a 40 seats bus. :slight_smile: It would be nice to have built-in configuration check before applying it to receiver.