HOME BLOG SHOP FORUM CONTACT US TERMS

NTRIP base compatibility?

I have been trying for some weeks to get Polaris Alpha to get into RTK fixed mode.

I have found one public NTRIP which will get me into RTK mode but only in float however long I wait (probably because it is 100km away).

A much nearer base does connect using Lefebure client but never gets into RTK mode.

Comparing the caster table entries for the 2 bases I see -

The 100km+ base sends: RTCM 3.0 messages
1004(1),1006(5),1012(1)

The <10km base sends: RTCM 3.2 messages 1005(1),1074(1),1084(1),1094(1),1124(1),1230(1)

Is this the cause of the problem? Is Polaris not compatible will all current RTCM standards?

If so, is there a solution eg firmware update?

Hi, try with GPS+BEIDOU configuration

Thank you. I have previously tried GPS+BEIDOU firmware to communicate with nearby NTRIP base (it is GPS+GLO+GAL+BDS) but it was no better (I am now sure it is because that base is RTCM v3.2 and Alpha supports v3.1 max).

I didn’t try it with the 100km+ base because it doesn’t support Beidou - just GPS and Glosnas. Presumably you don’t expect reloading the GPS+BEIDOU to help with that one?

I can’t test at the moment because my Alpha is broken but (see other post) I am thinking to have any hope of it working I need to find a NTRIP caster which sends the RTCM message numbers which Alpha needs/understands. But I don’t know which message numbers to look for. Do you?

Hi BII,

  1. The long baseline length can be an issue: baseline length is suggested to be within 7 KM for this single frequency receiver.
  2. RTCM v3.2 is compatible with Alpha receiver
  3. the nearby NTRIP base (GPS+GLO+GAL+BDS) seems to be ok. Is there any chance you can record correction data from base (using strsvr) and correction data from rover (in SD card) and also show the visible satellites numbers?

Hi,
Can you try to disable BeiDou reception and let me know if it helps? (follow this A tip to improve Alpha’s positioning accuracy when doing RTK/PPK with a VRS/CORS source, select GPS only)
If this improves RTK positioning, I will show you a further tip about BeiDou that we found recently.

Jim,

Sorry I didn’t get back to you. As I told @enricvil above my Alpha was broken (the USB socket had come off) see picture. It is unfortunate that the SD holder is on the other side of the board at the exact same place as that has forced you to surface mount rather than stick the lugs through the board as in most designs which would have given more mechanical strength.

After Christmas I bought a TTL to USB adapter and connected it to the 6 pin socket. Data seemed to be flowing but I still could not get it to do much. This week I tried to decode the data to understand why it is not working and I see it is sending text telling me to enter the licence code.

I remember now you that sent me one code to use to the end of 2019 and another for 2020.

I tried to input the new licence using RTK-VIEWER but it would not connect using my USB to TTL adapter. I tried soldering the USB connector back today but failed because it is so tiny.

  1. Please tell me how I get RTK-VIEWER to adjust the settings on my Alpha using the TTL port instead of the USB port. Do I need to use a USB-TTL adapter with a particular chip (mine is a FTDI one) or do I need a different version of the program?

  2. Please tell me what is the procedure to “factory reset” the device? I cannot find this in the manual. I am thinking that if that will clear the 2019 licence code it will stop saying only “$STI,invalid licence*48” and actually give me some usable DGPS NMEA which would be better than nothing.

Hi,
I will suggest you send the box back for USB socket fix.
The RTK Viewer does not send a command to TTL interface; you can only use TTL interface as RTK correction/NMEA data transmission.

Jim

Jim,

Thank you but I worry that if I do that when you return it I will have to pay a lot of tax and duty again like I had to the first time you sent it, and also the shipping back.

If so given that is already out of date kit being single frequency I wonder if the expense is worth it?

Can I know how to do the “factory reset” please so I can at least use it DGNS mode.

TTL port can only be used to deliver data of positioning; it does not support commands to go through it. Therefore no factory reset command can be done in your case.

If you are willing, we can try to find a way to avoid tax since this is a repair-and-return case.