HOME BLOG SHOP FORUM CONTACT US TERMS

PPK File Types Dont Work


#1

I have not been able to get anything to work. The files types from the alpha units are different from what shows in your YouTube video (.dat) and I cannot get them to work with rtklib. Any ideas?


#2

https://www.polaris-gnss.com/rtklib_2.4.3_b29.zip

What is the issue?


#3

yes i did all of that. but when i go to use RTKCONV and load my .DAT files from the alpha receivers the program says there is no usable data. but when i open the file as an ascii file all of the data is there. when i watch your youtube about the PPK process it shows that the files you are using from the alpha devices are a .obs file.


convert raw alpha data to rinex
#4

The .dat files are of binary type. Using RTKCONV from 2.4.3 version RTKLIB will convert it to RINEX format, which are .nav and .obs files. These in standard RINEX file format can be later post-processed using RTKPOST.

The .dat binary file from from Alpha SD-Card are similar to the .bin binary file seen in the blog video.


#5

Like This? Note it says there is no rinex data in the error log area.


#6

Looks like i found the issue. I switched the Format box from rinex to skytraq. I had done this before but it dose not work with older version on RTKCONV (2.4.2) i downloaded the link you provided above in this forum https://www.polaris-gnss.com/rtklib_2.4.3_b29.zip and it worked. Now to find out how to get the plots from RTKPOST…


#7

Yep looks like my Rover.obs and Base.obs files are working and full of recorded data. now my problem is when using RTKPOST. when i load both the Rover.obs and Base.obs into there appropriate drop boxes and hit execute the Rover.Pos file that is produced opens but has Content data other then the header info. So naturally when i click on the Plot button i get a no solution data error. I have attached my rover.pos file to review.

Is it possible the camera shutter single is the issue? or should there be some data regardless?


#8

I still have not got this to work. Any ideas? Did you take a look at the rover.pos file?


#9

i double checked the single from the shutter of the camera and its working. So then i ran another flight mission and nothing at all for data. No points from when the pictures were taken either. Any help at all would be great.


#10

Let’s try anther appraoch, please check out section 10 on page-30: http://navspark.mybigcommerce.com/content/NS-HP-GN-User-Guide_rev0.1.pdf See if this works for you. Below post-process program works on the SD Card binary log files directly.

http://navspark.mybigcommerce.com/content/RPP_GPS_GLO.zip


#11

So this problem never solve.


#12

No it did not… i had spent to many hours to make it work so i gave up and went a different route


#13

Probably, Alpha is not the right RTK for PPK.

However, this RTK Starter Kit with Raw Measurement Output RTKLIB Compatible might work.

https://www.polaris-gnss.com/shop-product-fullwidth/alpha-rtk-kit[1][1][1][2][1][1]?previous_url_id=0

My quadrone will be flying between 10m/s to 12m/s for mapping at 60m altitude.


#14

The starter kit only has a 1hz update rate compared to the standard alpha has up to 10hz it also has some other limitations as well… read the specs of both units before purchasing.


#15

OK. I understand now that Alpha RTK GNSS Receiver, might not work with PPK since it is not camera controls system.

https://docs.emlid.com/reachrs/common/reachview/camera-control/

More info on RTK Settings for PPK flight
https://docs.emlid.com/reachrs/common/reachview/rtk-settings/#gnss-selection-for-time-marks-logging


#16

You can use autopilot to trigger camera and log the positions of taking picture in Alpha’s SD card.

What is your plan?


#17

I recommend giving people a more in depth guide from start to finish for georeferencing ortho photos via your ppk system with specific systems like DJI, Ardino, etc. Maybe you guys got it to work with your own drone system but to be honest the time i spent trying to get it to work got so taxing i just gave up and went with a plug and play system. Im not saying your product dosnt work. But it didnt work for me. Good luck


#18

You can use autopilot to trigger camera and log the positions of taking picture in Alpha’s SD card.

You meant Ardupilot.

What is your plan?

Use Alpha RTK GNSS for Ardupilot Pixhawk UAV Mapping with PPK.

I am using Pixhawk with GPS and done several geotagging using Mission Planner for mapping job.

We know you use Ardupilot and mission planner to configure Alpha RTK GNSS in Pixhawk which is really good.

Yes, Alpha RTK is good for navigation already in Ardupilot. However, you have not completed the main purpose why Ardupilot people are buying RTK GNSS which is mapping using PPK.

Please show us how you “log the positions of taking picture in Alpha’s SD card” to do geotagging aerial photos and PPK.

We are really interest to see how “log the positions of taking picture in Alpha’s SD card” for PPK.

I think people we buying your RTK GNSS when you show us to do the PPK.

Thanks.


#19

Please allow us some time, we will show you.


#20

OK. Thanks.

Looking forward to see PPK tutorials using Polaris Alpha RTK GNSS

Logging
https://docs.emlid.com/reachrs/common/reachview/logging/

PPK, RTKLIB and RTKLIB RTKPOST
https://docs.emlid.com/reachrs/common/tutorials/gps-post-processing/

Thanks a lot.