HOME BLOG SHOP FORUM CONTACT US TERMS

RtkViewer.exe crashes (REASON DETECTED) (update released)

Following the https://www.polaris-gnss.com/quickstart.pdf

Downloading and installing the drivers goes smooth, but when I run the RtkViewer.exe I fisrt get an alert from Symantec that the program is not same and allowing the program to run anyways, it crashes shortly after hitting the Connect-button (see attached screenshot). I’ve set the COM Port and Baud Rate identical in the app and in the Device Manager.

What to do next?

Some customers that experience this issue have it resolved by maximizing RTK Viewer to full screen mode before making UART connection, i.e. clicking the rectangle beside the “X” on upper right corner of the RTK Viewer program.

If this doesn’t resolve the issue, please use this version that print out additional debug info for us: www.polaris-gnss.com/RtkViewer-20181018(1.0.0.4).zip , help capture the crash screen image for us. Thank you.

I’ve tried the original RtkViewer.exe on Win10 and on Win7 and it crashes full screen or not. I’ve also tested the debug version you linked in your response and it crashes as well on Win10. Where would it print the additional debug info as I cannot find any log anywhere?

EDIT: While in Rtk Viewer: when unpluggin the Alpha USB from the PC and replugging the USB the green Connect-button in the Rtk Viewer doesn’t press when clicking it.

Hello

I just received the GPS yesterday, and tried today to configure it, and I am having the same error in both Windows XP and Windows 10 (see attached screenshot) after having purchased the monthly license. Can you please help me as well?

thanks

Could you please provide a screenshot of the display settings of your Windows environment? Like the following example:

After some testing I managed to get the RTKViewer up and running. The issue on my side was Windows system language, which was not English. After setting it to English (United Kingdom) the RTKViewer is now working. In the long term in would be good to have the RTKViewer working on other system language too.

RTKViewer on Windows 10?

Latest 1.0.0.7 version RTK Viewer should have fixed the reported crash issue, connect issue, and exit issues.

Hello, Rtk viewer 1.0.0.4 can not be updated, the server did not respond.
Could you hang a link to download the latest version Rtk viewer 1.0.0.7?
Thank you.

https://www.polaris-gnss.com/rtk-viewer.zip

The above link always contains the latest version RTK Viewer.

In case there is any issue executing to RTK Viewer screen while it updates, paste %LOCALAPPDATA% to File Manager, delete the Polaris directory on that directory level, then execute the latest version RTK Viewer again.

Thank you very much for your help

hello after the update of rtk viewer I find myself with an error the alpha is not recognized yet the driver is well installed how to update alphas it can be useful to activate alpha




after

Hi romucifer,

Of the two Alphas you have, are both receiver having this unable to connect issue? Or only one Alpha having this reporting Device in ROM mode connecting in 9600 issue? Our engineering is working on a solution to recover from this Device in ROM mode state.

In case you have Device Detection Failed issue with the 2nd Alpha, please see if using different baud rate to connect (4800 / 9600 / 38400 / 115200) will will enable RTK Viewer to detect Alpha. Thank you.

hello yes 2 alpha in rom mode

Try the following steps to restore firmware from ROM mode.

  1. Open RTK Viewer, connect Alpha at 9600 baud. (If it fails, please try again)

  2. Run “Check Firmware Update” in Updates menu. It will display the following screen.
    Step2

  3. Press the “Download and Update” button and wait for completion. After the update is completed, “Firmware update failed” will be displayed. Don’t worry, it’s okay.

  4. Close all dialog and back to main screen and remove the USB cable from Alpha. After confirming that Alpha is completely powered off, connect the USB cable to Alpha and connect RTK Viewer with Alpha at 115200 baud rate.

  5. Do a “Check Firmware Update” after successful connection. If it is not the latest firmware, update it again.

  6. The default recovered firmware is GPS/Beidou RTK type. For non-Asian customers that should use GPS/GLONASS RTK firmware, run “Alpha RTK Receiver Type Configuration” in Updates menu. Press “Download and Update” and be sure to wait for it to complete.

Then Alpha should be restored back to normal state.

hello the server does not answer

Please confirm whether the RTK Viewer is allowed by “Windows Defender Firewall” in the Windows Control Panel.

  1. Open “Windows Defender Firewall with Advance Security” in Control Panel.
  2. Click “Inbound Rules”, search all “rtkviewer.exe” items for modification.
  3. Change the Action from “Block the connection” to “Allow the connection”. If there are multiple “rtkviewer.exe” items, modify them all.



yes old rtk viewer is good in windows defender firewall but server is not respond

i also test with firewalls disable but it does not work