Switch Broke straight away.

Hi guys,

Purchased RTK Alfa Lite package recently and received it 2 days ago. That’s fast. Thanks Polaris.

All looked great until I tried to configure it and move the switch. Something snapped and now I cannot switch to anything. I tried to look at where it was with a magnification glass but I cannot even see how it could work before. I can only see a lot of broken plastic pieces and it is even hard to guess what it is current position now.

I can probably remove screws(i guess that will void warranty) but I am familiar with similar type of switches and I do not think it will help me.

Can anyone recommend anything?

Can you post the picture of the (missing) switch?
I will then contact our engineering persons to see what is the best way to fix this.

I will try to find a way to picture it with magnification and post it asap.

I was able to test the unit with bluetooth and my smartphone running NTRIP and even the way it is(unconfigured) it tells me it has 1m accuracy.
The only problem it did not want to work on my Xiaomi Mi Max 2 phone(NTRIP client says it could not established bluetooth connection even it was paired). However it started and connected on My Samsung S6 Edge with no problem. Google Maps showed me exactly where I was and GPS test app said I had 1m accuracy.

For the current application 1m is a big improvement from me from a standard 5m but I also have a commercial drone where I want to use full RTK. If broken switch problem can be resolved in some way I will definitely going to buy another standart kit from Polaris and configure one to to act as a base and another as a rover.

Try to unplug/re-plug Alpha power. Sometimes Bluetooth connection difficulties happen.

I’d like to know more about your usage of Alpha.
You are now getting RTK correction data from a third party base?

I tried it many times but NTRIP could not connect to the receiver from this phone. On Samsung S6 Edge though it connected from the first try.

I could not configure or use it for anything yet. My idea was to use it with free Australian NTRIP caster provided by AUSCORS . Their bases are about 50 km from places I need more accurate coordinates but I am not expecting 2cm accuracy.

I would be happy with anything from 30cm to 100cm. This is just for one application(taking photos with more accurate GPS coordinates).

So after I broke that pin on the switch(or the switch as a whole) I just put it into Bluetooth mode on the receiver, followed all steps in manual as for setting it to work with a third party base. I just skipped the step where I needed to configure NTRIP caster. Clicked connect in NTRIP app and checked with third party GPS app and google maps what is accuracy. Third party app(GPS test) I used did not show any satellites and displayed “no fix” but it displayed 1m accuracy. And google map put me exactly where the antenna was while with built in the phone GPS it always a few meters off.

The second application I hoped to use it in the future would be for a drone and I was planing to get another kit from Polaris to set up my own base. But this is a future project, I need to sort out broken pin on the switch, just to see how it works with photos before I can go with purchasing another kit.

I do not know in which position the switch right now. The first time I set it to A and when I tried to move it to B the pin on the switch came off and it probably took with itself a lot of plastic behind it. I did not apply too much pressure at all.


  1. forget the Alpha Bluetooth device
  2. scan Bluetooth device, find Alpha, pair it with phone
  3. use Polaris NTRIP Client app or Lefebure NTRIP Client app (Bluetooth Connection Method = Insecure) to communicate with Alpha

Hi Mike,
Can you send it back to us for fixing your switch?

It is actually not a bad idea as there is nothing to fix, the switch simply broken and need to be replaced. . I will check tomorrow how much it will cost to post it to you. Are you in HK?

Do not worry about helping me with xiaomi mi max 2 phone bluetooth connection problem. This phone has been stuffed with a lot of GPS apps. And before I got your kit I played with Lefebure NTRIP app a lot. I could possibly screwed it up myself. It works with Samsung S6 Edge. I will try to figure it out on Xiaomi phone later.

We are located in Taiwan.
Thank you for the update. You can judge if you want to fix it locally (we can send you the necessary spare components if you need) or send back to us for fix.
I will discuss more about your using scenario later.

I think The CORS base is to far for you to use as GNSS correcting data source. (the distance should be less than 7 KM) You may not have a fixed RTK position since the CORS GNSS data is too different than what your rover get.

You can have a good result if you have the same plan with this user (Alpha RTK on phantom 4 for PPK), who use a gps-enabled camera to take pictures with accurate time and date, and he do time-maching with PPK data.

[quote=“jim, post:2, topic:291, full:true”]
Can you post the picture of the (missing) switch?
I will then contact our engineering persons to see what is the best way to fix this.

Please see the picture attached. Sorry it took me so long to get it.
As you can see it looks like a lot of plastic came off from that switch when the pin snapped off it.

Can you please provide your return address. Is it the same as on your envelope that was inside a fedex satchel?

Send to

Jim Lin
3F, 26, Minsiang Street
Hsinchu City, Taiwan 300

Please check this topic out. Perhaps it helps your work with Alpha and VRS/CORS.

Jim Lin
Polaris GNSS Team

Hi Jim, I have posted it for repair to the address above. There is also a note inside a box. Please check it as well.

Will do. Sorry for the inconvenience.

I have the same problem and the switch has broken on one of my Alphas. Where can I send it for repairs?

Please consider the two options:

  1. We send you replace parts of the switch, and you fix it locally. This costs you
  2. You send Alpha back to us for fix. We will collect postage fee for sending Alpha back.