HOME BLOG SHOP FORUM CONTACT US TERMS

Unable to get RTK Fix (Issue Found: CORS not working correctly for VRS)

After LOTS of trials it has been impossible to get RTK fix more than 15 seconds.

I have tried long baselines at first (RTKView indicated 32 kma baseline which is strange because I am using VRS solution and baseline should be shorter to my knowledge, it basically took an antenna that is at that distance). Under such scenario only a couple of times and a couple of seconds of RTK FIX. The rest mostly float and some DGPS.

Then moved to an open sky environment at 6kms baseline. Tested all possible solutions (VRS3, VRS2, CERCANA, lots of what out CORS national system offers). I have tried to reflash my unit to select Baidou (it worked the same, although there were less satellites than with GPS+GLONASS).

I am getting 13-15 satellites all the time with no luck. Tried all configuration parameters (1-10Hz) with a perfect 4g connection for corrections.

No more things to test. I am afraid I will have to surrender about the possibility of using Alpha as a GIS platform. It just does not work. Nothing like the videos shown on this page, perhaps because the system runs better for Baidou, not the case in Spain where I live (and it seems I am not the only one here in my location as have been contacted about this).

It is a pity, hope something can be done about this. I was really hopeful I could find an affordable solution for GIS Operation.

Any suggestions?

Remeber that when using VRS you need to provide your location, so that the provided VRS base station will have short baseline. Also have clear unobstructed skyview with signals above 40dB, more number of such satellite the better.

If you cannot get stable RTK fix, please provide us 20 minutes simultaneous log files of the RTCM data and the Alpha receiver raw measurement data. We need both base RTCM and rover raw measurement data to analyze for possible cause. Logging of the raw measurement to SD card can be done by method described in Table 3-1 item #6 of the user guide. Remember to stop SD card logging before retrieving the file.

Your location can have 11 ~ 16 GPS/GLONASS satellites above 15 degree elevation angle; Alpha only uses satellite above 15 degree elevation angle for RTK. When first testing or logging data for us to analyze, please see if can choose convenient hour with more satellites and widely spread across 4 quadrant of the sky with low HDOP.

Thanks, Jackson

When you say that I must provide position with VRS, is there something I must manually enter? I just tell Lefebure to get position from external receiver.

I will get Logs and come back to you.

Thanks,

Jose

I’ll need to get an VRS account to test Lefebure NTRIP client and get back to you tomorrow.

Telling Lefebure NTRIP Client getting from External Receiver to report location with VRS base station, I see the baseline is only 1 ~ 2 meters. So your getting 6Km baseline with VRS is something abnormal.

So there must be something wrong with compatibility with our national GNSS correction system. I will contact them and ask about it.

No luck yet. Always getting as baseline the distance to the real base station even when selecting VRS. I have tried all connections points to no avail… Any suggestions? One thing that I consider strange is when selecting the position for NTRIP client from Android, I can read on Lefebure log the coordinates I am getting from it. But if I select the receiver, no coordinates are shown on the log. Just a message about waiting for GGE and then it continues running but no coordinates are shown. Is this ok?

When directly setting user coordinate to Lefebure NTRIP Client for VRS testing using Report Location --> Manual Lat-Lon, we see 1 ~ 2 hundred meter baseline, not sure why, but it’s better than 6Km baseline trying to get RTK Fix, good enough.

No way. Even entering coordinates manually I get 32 kms baseline! Is there any log I can pass to you.

You can send us both 15 minutes RTCM log file and SD card log file to check.

Which format is supposed to be sent over GGA?: Because my GPS log says this:

$GPGGA,160840.000,3646.6015585,N,00248.3838117,W,2,11,0.9,81.001,M,52.800,M,0000*7C

3646.6015585,N,00248.3838117,W do not look like correct coordinates, mine were: 36.46 and -2.28 (is that any kind of codification?)

Oh, well, I found it… it is codified and seems correct… Our CORS national system is not understanding something or is not working propely for VRS (which is hard to understand taking into account it is used all days by a lot of people)

Hi,
Please check this topic out. Perhaps it helps your work with Alpha and VRS/CORS.

Jim Lin
Polaris GNSS Team

Hi, I have just done the tip… What happens now is that RtkViewer doesnt’t recognise Alpha when connecting. Any solution?
Thanks,

Hi,
RTK Viewer does not detect and show your device insertion?
Does GNSS Viewer has the same phenomenon?

Hi, gnns viewer works fine, I solved the problem reflashing alpha with the first configuration (gps+glonass). Rtk viewer recognise alpha now again! What happens now is that the first led doesn’t work (fix led)…

Hi,
Thank you for the update.
Do you mean, you have a Fixed RTK status, but the LED does not work properly? In that case I will contact our engineering persons to look into it.

Yes, in my case, in GPS+BEIDOU configuration, the first led never works (with or without fixed RTK),

Thanks,

Hi,
It is a bug of firmware. We just fixed it and released a new version of firmware, please try it.
Thank you for the information!

Hello, I hook up to this topic because I have a similar problem. If so, please give me instructions on how to improve my Alpha. Here is my case: My Alpha RTK Std. The device configured as “Rover”, 1 Hz (previously tried 5 Hz, 10 Hz). Correction signal is generally provided by the Polish company ASGEupos. I conducted communication tests at distances from 1.5 km to 34 km from the Ntrip transmitter. I checked 2 GSM operators with the best transmission quality (according to experienced users). I use Leferbure Ntrip Client to connect. He obtains Float RTK without major problems. The problem is getting Fix RTK! I consulted the problem with the RTK patch provider. Communication via GSM is with the base. My device is not sending its coordinators correctly! (in the NMEA protocol, the GGA message happens to be 0.00 or minus and my location is about 30 km north of Krakow). Although, according to the specialist, this should not matter for RTK patches, it is necessary for RTN patches. Fix RTK and RTN in various signal configurations too short-lived. It is not useful! Please help, because from the day of registration I can not yet use the precise positioning of the Fix RTK Alpha device (Fix RTK appears sporadically. A few seconds per hour).